In short
- CVE-2000-0725 is a HIGH (CVSS 7.2) vulnerability affecting zope, zope (zope).
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.7% of all vulnerabilities.
- Fix: update to 2.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| zope PyPI | < 2.2.1
| 2.2.1
|
| zope | = 1.10.3= 2.1.1= 2.1.7= 2.2_beta1
| No fix yet |
Description
Zope before 2.2.1 does not properly restrict access to the getRoles method, which allows users who can edit DTML to add or modify roles by modifying the roles list that is included in a request.
NVD description
Zope before 2.2.1 does not properly restrict access to the getRoles method, which allows users who can edit DTML to add or modify roles by modifying the roles list that is included in a request.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free