In short
- CVE-2003-0043 is a MEDIUM (CVSS 5.0) vulnerability affecting org.apache.tomcat:tomcat, tomcat (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.5%, higher than 91.5% of all vulnerabilities.
- Fix: update to 3.3.1a or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat:tomcat Maven | < 3.3.1a
| 3.3.1a
|
| tomcat | = 3.0= 3.1= 3.1.1= 3.2= 3.2.1= 3.2.3= 3.2.4= 3.3= 3.3.1
| No fix yet |
Description
Jakarta Tomcat before 3.3.1a, when used with JDK 1.3.1 or earlier, uses trusted privileges when processing the web.xml file, which could allow remote attackers to read portions of some files through the web.xml file.
NVD description
Jakarta Tomcat before 3.3.1a, when used with JDK 1.3.1 or earlier, uses trusted privileges when processing the web.xml file, which could allow remote attackers to read portions of some files through the web.xml file.
More vulnerabilities in org.apache.tomcat:tomcat
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free