In short
- CVE-2006-1546 is a HIGH (CVSS 7.5) vulnerability affecting struts:struts, struts (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.3%, higher than 93.6% of all vulnerabilities.
- Fix: update to 1.2.9 or later.
Description
Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to bypass validation via a request with a 'org.apache.struts.taglib.html.Constants.CANCEL' parameter, which causes the action to be canceled but would not be detected from applications that do not use the isCancelled check.
NVD description
Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to bypass validation via a request with a 'org.apache.struts.taglib.html.Constants.CANCEL' parameter, which causes the action to be canceled but would not be detected from applications that do not use the isCancelled check.
More vulnerabilities in struts:struts
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free