In short
- CVE-2006-1548 is a MEDIUM (CVSS 4.3) vulnerability affecting struts:struts, struts (apache).
- Chance of exploitation in the next 30 days (EPSS): 5.5%, higher than 92.7% of all vulnerabilities.
- Fix: update to 1.2.9 or later.
Description
Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.
NVD description
Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.
More vulnerabilities in struts:struts
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free