In short
- CVE-2007-0404 is a HIGH (CVSS 7.5) vulnerability affecting django, django (django project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.4% of all vulnerabilities.
- Fix: update to 1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 0.95, < 1.0
| 1.0
|
| django | = 0.95
| No fix yet |
Description
bin/compile-messages.py in Django 0.95 does not quote argument strings before invoking the msgfmt program through the os.system function, which allows attackers to execute arbitrary commands via shell metacharacters in a (1) .po or (2) .mo file.
NVD description
bin/compile-messages.py in Django 0.95 does not quote argument strings before invoking the msgfmt program through the os.system function, which allows attackers to execute arbitrary commands via shell metacharacters in a (1) .po or (2) .mo file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free