In short
- CVE-2007-0405 is a MEDIUM (CVSS 6.5) vulnerability affecting django, django (django project).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.6% of all vulnerabilities.
- Fix: update to 1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 0.95, < 1.0
| 1.0
|
| django | = 0.95
| No fix yet |
Description
The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly cache the user name across requests, which allows remote authenticated users to gain the privileges of a different user.
NVD description
The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly cache the user name across requests, which allows remote authenticated users to gain the privileges of a different user.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free