In short
- CVE-2007-6183 is a MEDIUM (CVSS 6.8) vulnerability affecting gtk2, ruby gnome2 (ruby gnome2).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.9% of all vulnerabilities.
- Fix: update to 0.17.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gtk2 RubyGems | < 0.17.0
| 0.17.0
|
| ruby gnome2 | = 0.16.0
| No fix yet |
Description
Format string vulnerability in the mdiag_initialize function in gtk/src/rbgtkmessagedialog.c in Ruby-GNOME 2 (aka Ruby/Gnome2) 0.16.0, and SVN versions before 20071127, allows context-dependent attackers to execute arbitrary code via format string specifiers in the message parameter.
NVD description
Format string vulnerability in the mdiag_initialize function in gtk/src/rbgtkmessagedialog.c in Ruby-GNOME 2 (aka Ruby/Gnome2) 0.16.0, and SVN versions before 20071127, allows context-dependent attackers to execute arbitrary code via format string specifiers in the message parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free