In short
- CVE-2008-2025 is a MEDIUM (CVSS 4.3) vulnerability affecting struts:struts, struts (apache).
- Chance of exploitation in the next 30 days (EPSS): 7.9%, higher than 94.7% of all vulnerabilities.
- Fix: update to 1.2.9-162.31.1 or later.
| Package | Affected versions | Patched versions |
|---|
| struts:struts Maven | < 1.2.9-162.31.1
| 1.2.9-162.31.1
|
| struts | = 1.0.2= 1.1= 1.2.4= 1.2.7= 1.2.8
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to "insufficient quoting of parameters."
NVD description
Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to "insufficient quoting of parameters."
More vulnerabilities in struts:struts
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free