In short
- CVE-2008-2942 is a MEDIUM (CVSS 6.8) vulnerability affecting mercurial, mercurial (mercurial).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.7% of all vulnerabilities.
- Fix: update to 1.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| mercurial PyPI | < 1.0.2
| 1.0.2
|
| mercurial | = 1.0.1
| No fix yet |
Description
Directory traversal vulnerability in patch.py in Mercurial before 1.0.2 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file.
NVD description
Directory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free