In short
- CVE-2008-6549 is a MEDIUM (CVSS 5.0) vulnerability affecting moin, moinmoin (moinmo).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.0% of all vulnerabilities.
- Fix: update to 1.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| moin PyPI | < 1.6.1
| 1.6.1
|
| moinmoin | = 1.6.1
| No fix yet |
Description
The password_checker function in config/multiconfig.py in MoinMoin prior to version 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.
NVD description
The password_checker function in config/multiconfig.py in MoinMoin 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free