In short
- CVE-2008-7310 is a MEDIUM (CVSS 5.0) vulnerability affecting spree, spree (spreecommerce).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.9% of all vulnerabilities.
- Fix: update to 0.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| spree RubyGems | < 0.4.0
| 0.4.0
|
| spree | = 0.2.0
| No fix yet |
Description
Spree 0.2.0 does not properly restrict the use of a hash to provide values for a model's attributes, which allows remote attackers to set the Order state value and bypass the intended payment step via a modified URL, related to a "mass assignment" vulnerability.
NVD description
Spree 0.2.0 does not properly restrict the use of a hash to provide values for a model's attributes, which allows remote attackers to set the Order state value and bypass the intended payment step via a modified URL, related to a "mass assignment" vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free