In short
- CVE-2008-7311 is a MEDIUM (CVSS 5.0) vulnerability affecting spree, spree (spreecommerce).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.9% of all vulnerabilities.
- Fix: update to 0.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| spree RubyGems | < 0.4.0
| 0.4.0
|
| spree | = 0.2.0
| No fix yet |
Description
The session cookie store implementation in Spree 0.2.0 uses a hardcoded config.action_controller_session hash value (aka secret key), which makes it easier for remote attackers to bypass cryptographic protection mechanisms by leveraging an application that contains this value within the config/environment.rb file.
NVD description
The session cookie store implementation in Spree 0.2.0 uses a hardcoded config.action_controller_session hash value (aka secret key), which makes it easier for remote attackers to bypass cryptographic protection mechanisms by leveraging an application that contains this value within the config/environment.rb file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free