In short
- CVE-2009-0783 is a MEDIUM (CVSS 4.2) vulnerability affecting org.apache.tomcat:tomcat, tomcat (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 56.9% of all vulnerabilities.
- Fix: update to 6.0.20 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat:tomcat Maven | ≥ 4.1.0, ≤ 4.1.39≥ 5.5.0, ≤ 5.5.27≥ 6.0.0, < 6.0.20
| 6.0.20
|
| tomcat | ≥ 4.1.0, ≤ 4.1.39≥ 5.5.0, ≤ 5.5.27≥ 6.0.0, ≤ 6.0.18
| No fix yet |
Description
Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the (1) web.xml, (2) context.xml, or (3) tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application.
NVD description
Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the (1) web.xml, (2) context.xml, or (3) tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application.
More vulnerabilities in org.apache.tomcat:tomcat
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free