In short
- CVE-2009-3695 is a MEDIUM (CVSS 5.0) vulnerability affecting django, django (djangoproject).
- Chance of exploitation in the next 30 days (EPSS): 3.7%, higher than 89.8% of all vulnerabilities.
- Fix: update to 1.0.4, 1.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 1.0, < 1.0.4≥ 1.1, < 1.1.1
| 1.0.41.1.1
|
| django | = 1.0= 1.1
| No fix yet |
Description
Algorithmic complexity vulnerability in the forms library in Django 1.0 before 1.0.4 and 1.1 before 1.1.1 allows remote attackers to cause a denial of service (CPU consumption) via a crafted (1) EmailField (email address) or (2) URLField (URL) that triggers a large amount of backtracking in a regular expression.
NVD description
Algorithmic complexity vulnerability in the forms library in Django 1.0 before 1.0.4 and 1.1 before 1.1.1 allows remote attackers to cause a denial of service (CPU consumption) via a crafted (1) EmailField (email address) or (2) URLField (URL) that triggers a large amount of backtracking in a regular expression.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free