In short
- CVE-2010-3082 is a MEDIUM (CVSS 4.3) vulnerability affecting django, django (djangoproject).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.9% of all vulnerabilities.
- Fix: update to 1.2.2 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 1.2, < 1.2.2
| 1.2.2
|
| django | = 1.2.1= 1.2.2
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in Django 1.2.x before 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a csrfmiddlewaretoken (aka csrf_token) cookie.
NVD description
Cross-site scripting (XSS) vulnerability in Django 1.2.x before 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a csrfmiddlewaretoken (aka csrf_token) cookie.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free