In short
- CVE-2010-3933 is a MEDIUM (CVSS 6.4) vulnerability affecting activerecord, rails (rubyonrails).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.6% of all vulnerabilities.
- Fix: update to 2.3.10, 3.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| activerecord RubyGems | ≥ 2.3.9, < 2.3.10≥ 3.0.0, < 3.0.1
| 2.3.103.0.1
|
| rails | = 2.3.9= 3.0.0
| No fix yet |
Description
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
NVD description
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
More vulnerabilities in activerecord
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free