In short
- CVE-2011-1419 is a MEDIUM (CVSS 5.8) vulnerability affecting org.apache.tomcat:tomcat, tomcat (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.5%, higher than 93.8% of all vulnerabilities.
- Fix: update to 7.0.11 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat:tomcat Maven | ≥ 7.0, < 7.0.11
| 7.0.11
|
| tomcat | = 7.0.0= 7.0.1= 7.0.10= 7.0.2= 7.0.3= 7.0.4= 7.0.5= 7.0.6= 7.0.7= 7.0.8= 7.0.9
| No fix yet |
Description
Apache Tomcat 7.x before 7.0.11, when web.xml has no security constraints, does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1088.
NVD description
Apache Tomcat 7.x before 7.0.11, when web.xml has no security constraints, does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1088.
More vulnerabilities in org.apache.tomcat:tomcat
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free