In short
- CVE-2011-2765 is a HIGH (CVSS 7.5) vulnerability affecting pyro, pyro (pyro project).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.7% of all vulnerabilities.
- Fix: update to 3.15 or later.
| Package | Affected versions | Patched versions |
|---|
| pyro PyPI | < 3.15
| 3.15
|
| pyro | < 3.15
| 3.15
|
Description
pyro before 3.15 unsafely handles pid files in temporary directory locations and opening the pid file as root. An attacker can use this flaw to overwrite arbitrary files via symlinks.
NVD description
pyro before 3.15 unsafely handles pid files in temporary directory locations and opening the pid file as root. An attacker can use this flaw to overwrite arbitrary files via symlinks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free