In short
- CVE-2011-4962 is a MEDIUM (CVSS 6.8) vulnerability affecting silverstripe/cms, silverstripe (silverstripe).
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.3% of all vulnerabilities.
- Fix: update to 2.4.6 or later.
| Package | Affected versions | Patched versions |
|---|
| silverstripe/cms Packagist | ≥ 2.4.0, < 2.4.6
| 2.4.6
|
| silverstripe | = 2.4.0= 2.4.1= 2.4.2= 2.4.3= 2.4.4= 2.4.5
| No fix yet |
Description
code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow remote attackers to execute arbitrary code via a crafted cookie in a user comment submission, which is not properly handled when it is deserialized.
NVD description
code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow remote attackers to execute arbitrary code via a crafted cookie in a user comment submission, which is not properly handled when it is deserialized.
More vulnerabilities in silverstripe/cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free