In short
- CVE-2012-0215 is a MEDIUM (CVSS 5.5) vulnerability affecting trytond, trytond (tryton).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.6% of all vulnerabilities.
- Fix: update to 2.2.4, 2.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| trytond PyPI | < 2.2.4< 2.4.0
| 2.2.42.4.0
|
| trytond | = 1.4.13= 1.6.8= 1.8.7= 2.0.5≤ 2.2.3
| No fix yet |
Description
model/modelstorage.py in the Tryton application framework (trytond) before 2.4.0 for Python does not properly restrict access to the Many2Many field in the relation model, which allows remote authenticated users to modify the privileges of arbitrary users via a (1) create, (2) write, (3) delete, or (4) copy rpc call.
NVD description
model/modelstorage.py in the Tryton application framework (trytond) before 2.4.0 for Python does not properly restrict access to the Many2Many field in the relation model, which allows remote authenticated users to modify the privileges of arbitrary users via a (1) create, (2) write, (3) delete, or (4) copy rpc call.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free