In short
- CVE-2012-0878 is a MEDIUM (CVSS 5.1) vulnerability affecting paste, pastescript, paste (pythonpaste).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.6% of all vulnerabilities.
- Fix: update to 1.7.5.1, 2.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| paste PyPI | < 1.7.5.1
| 1.7.5.1
|
| pastescript PyPI | < 2.0.1
| 2.0.1
|
| paste | ≤ 1.7.5
| No fix yet |
Description
Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.
NVD description
Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free