In short
- CVE-2012-1157 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.6% of all vulnerabilities.
- Fix: update to 2.0.8, 2.1.5, 2.2.2, 1.9.17 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 2.0, < 2.0.8≥ 2.1, < 2.1.5≥ 2.2, < 2.2.2< 1.9.17
| 2.0.82.1.52.2.21.9.17
|
| moodle | < 2.2.2
| 2.2.2
|
Description
Moodle before 2.2.2 default settings allowed all repositories to be viewable by all authenticated users.
NVD description
Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free