In short
- CVE-2012-1176 is a MEDIUM (CVSS 5.0) vulnerability affecting pyfribidi, pyfribidi (fribidi).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 85.8% of all vulnerabilities.
- Fix: update to 0.11.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pyfribidi PyPI | < 0.11.0
| 0.11.0
|
| pyfribidi | ≤ 0.10.9
| No fix yet |
Description
Buffer overflow in the fribidi_utf8_to_unicode function in PyFriBidi before 0.11.0 allows remote attackers to cause a denial of service (application crash) via a 4-byte utf-8 sequence.
NVD description
Buffer overflow in the fribidi_utf8_to_unicode function in PyFriBidi before 0.11.0 allows remote attackers to cause a denial of service (application crash) via a 4-byte utf-8 sequence.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free