In short
- CVE-2012-1826 is a MEDIUM (CVSS 6.0) vulnerability affecting com.dotcms:dotcms, dotcms (dotcms).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.2% of all vulnerabilities.
- Fix: update to 1.9.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| com.dotcms:dotcms Maven | ≥ 1.9, < 1.9.5.1
| 1.9.5.1
|
| dotcms | = 1.9= 1.9.2.1
| No fix yet |
Description
dotCMS 1.9 before 1.9.5.1 allows remote authenticated users to execute arbitrary Java code via a crafted (1) XSLT or (2) Velocity template.
NVD description
dotCMS 1.9 before 1.9.5.1 allows remote authenticated users to execute arbitrary Java code via a crafted (1) XSLT or (2) Velocity template.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free