In short
- CVE-2012-2356 is a MEDIUM (CVSS 4.0) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.8% of all vulnerabilities.
- Fix: update to 2.1.6, 2.2.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 2.1, < 2.1.6≥ 2.2, < 2.2.3
| 2.1.62.2.3
|
| moodle | = 2.1.0= 2.1.1= 2.1.2= 2.1.3= 2.1.4= 2.1.5= 2.2.0= 2.2.1= 2.2.2
| No fix yet |
Description
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
NVD description
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free