In short
- CVE-2012-3426 is a MEDIUM (CVSS 4.9) vulnerability affecting keystone, horizon (openstack), keystone (openstack).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.3% of all vulnerabilities.
- Fix: update to 8.0.0a0 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0a0all versions
| 8.0.0a0
|
| horizon | = folsom-1
| No fix yet |
| keystone | = 2012.1= 2012.1.1
| No fix yet |
Description
OpenStack Keystone before 2012.1.1, as used in OpenStack Folsom before Folsom-1 and OpenStack Essex, does not properly implement token expiration, which allows remote authenticated users to bypass intended authorization restrictions by (1) creating new tokens through token chaining, (2) leveraging possession of a token for a disabled user account, or (3) leveraging possession of a token for an account with a changed password.
NVD description
OpenStack Keystone before 2012.1.1, as used in OpenStack Folsom before Folsom-1 and OpenStack Essex, does not properly implement token expiration, which allows remote authenticated users to bypass intended authorization restrictions by (1) creating new tokens through token chaining, (2) leveraging possession of a token for a disabled user account, or (3) leveraging possession of a token for an account with a changed password.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free