In short
- CVE-2012-3442 is a MEDIUM (CVSS 4.3) vulnerability affecting django, django (djangoproject).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.5% of all vulnerabilities.
- Fix: update to 1.4.1, 1.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 1.4, < 1.4.1< 1.3.2
| 1.4.11.3.2
|
| django | = 1.4< 1.3.2
| 1.3.2
|
Description
The (1) django.http.HttpResponseRedirect and (2) django.http.HttpResponsePermanentRedirect classes in Django before 1.3.2 and 1.4.x before 1.4.1 do not validate the scheme of a redirect target, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via a data: URL.
NVD description
The (1) django.http.HttpResponseRedirect and (2) django.http.HttpResponsePermanentRedirect classes in Django before 1.3.2 and 1.4.x before 1.4.1 do not validate the scheme of a redirect target, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via a data: URL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free