In short
- CVE-2012-3458 is a MEDIUM (CVSS 4.3) vulnerability affecting beaker, beaker (python).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.5% of all vulnerabilities.
- Fix: update to 1.6.4, 1.6.5.post1 or later.
| Package | Affected versions | Patched versions |
|---|
| beaker PyPI | < 1.6.4< 1.6.5.post1
| 1.6.41.6.5.post1
|
| beaker | ≤ 1.6.4
| No fix yet |
Description
Beaker before 1.6.4, when using PyCrypto to encrypt sessions, uses AES in ECB cipher mode, which might allow remote attackers to obtain portions of sensitive session data via unspecified vectors.
NVD description
Beaker before 1.6.4, when using PyCrypto to encrypt sessions, uses AES in ECB cipher mode, which might allow remote attackers to obtain portions of sensitive session data via unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free