In short
- CVE-2012-5563 is a MEDIUM (CVSS 4.0) vulnerability affecting keystone, folsom (openstack).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.8% of all vulnerabilities.
- Fix: update to 8.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0all versions
| 8.0.0
|
| folsom | = 2012.2
| No fix yet |
Description
OpenStack Keystone, as used in OpenStack Folsom 2012.2, does not properly implement token expiration, which allows remote authenticated users to bypass intended authorization restrictions by creating new tokens through token chaining. NOTE: this issue exists because of a CVE-2012-3426 regression.
NVD description
OpenStack Keystone, as used in OpenStack Folsom 2012.2, does not properly implement token expiration, which allows remote authenticated users to bypass intended authorization restrictions by creating new tokens through token chaining. NOTE: this issue exists because of a CVE-2012-3426 regression.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free