In short
- CVE-2012-5825 is a HIGH (CVSS 7.4) vulnerability affecting tweepy, tweepy (tweepy).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 49.2% of all vulnerabilities.
- Fix: update to 2.3.1, 3.0, 3.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| tweepy PyPI | < 2.3.1< 3.0
| 2.3.13.0
|
| tweepy | < 3.0.0
| 3.0.0
|
Description
Tweepy does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate, related to use of the Python httplib library.
NVD description
Tweepy does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate, related to use of the Python httplib library.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free