In short
- CVE-2012-6497 is a MEDIUM (CVSS 5.0) vulnerability affecting authlogic, rails (rubyonrails).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.1% of all vulnerabilities.
- Fix: update to 3.3.0, 3.2.10 or later.
| Package | Affected versions | Patched versions |
|---|
| authlogic RubyGems | < 3.3.0
| 3.3.0
|
| rails | < 3.2.10
| 3.2.10
|
Description
The Authlogic gem for Ruby on Rails prior to version 3.3.0 makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.
NVD description
The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free