In short
- CVE-2013-0270 is a MEDIUM (CVSS 6.5) vulnerability affecting keystone, keystone (openstack).
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.0% of all vulnerabilities.
- Fix: update to 8.0.0a0 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0a0
| 8.0.0a0
|
| keystone | = 2013.1≥ 2012.1, ≤ 2012.1.3≥ 2012.2, ≤ 2012.2.4
| No fix yet |
Description
OpenStack Keystone Grizzly before 2013.1, Folsom, and possibly earlier allows remote attackers to cause a denial of service (CPU and memory consumption) via a large HTTP request, as demonstrated by a long tenant_name when requesting a token.
NVD description
A flaw was found in OpenStack Keystone. A remote attacker could exploit this vulnerability by sending a large HTTP request, specifically by providing a long tenant name when requesting a token. This could lead to a denial of service, consuming excessive CPU and memory resources on the affected system.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free