In short
- CVE-2013-0282 is a MEDIUM (CVSS 5.0) vulnerability affecting keystone, keystone (openstack).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.0% of all vulnerabilities.
- Fix: update to 8.0.0a0 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0a0
| 8.0.0a0
|
| keystone | = 2013.1≥ 2012.1, ≤ 2012.1.3≥ 2012.2, ≤ 2012.2.4
| No fix yet |
Description
OpenStack Keystone Grizzly before 2013.1, Folsom 2012.1.3 and earlier, and Essex does not properly check if the (1) user, (2) tenant, or (3) domain is enabled when using EC2-style authentication, which allows context-dependent attackers to bypass access restrictions.
NVD description
OpenStack Keystone Grizzly before 2013.1, Folsom 2012.1.3 and earlier, and Essex does not properly check if the (1) user, (2) tenant, or (3) domain is enabled when using EC2-style authentication, which allows context-dependent attackers to bypass access restrictions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free