In short
- CVE-2013-0294 is a MEDIUM (CVSS 5.9) vulnerability affecting pyrad, pyrad (pyrad project).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.8% of all vulnerabilities.
- Fix: update to 2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pyrad PyPI | < 2.1
| 2.1
|
| pyrad | < 2.1
| 2.1
|
Description
packet.py in pyrad before 2.1 uses weak random numbers to generate RADIUS authenticators and hash passwords, which makes it easier for remote attackers to obtain sensitive information via a brute force attack.
NVD description
packet.py in pyrad before 2.1 uses weak random numbers to generate RADIUS authenticators and hash passwords, which makes it easier for remote attackers to obtain sensitive information via a brute force attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free