In short
- CVE-2013-1630 is a MEDIUM (CVSS 6.8) vulnerability affecting pyshop, pyshop (guillaume gauvrit).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.7% of all vulnerabilities.
- Fix: update to 0.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pyshop PyPI | < 0.7.1
| 0.7.1
|
| pyshop | = 0.1= 0.2= 0.3= 0.4= 0.5= 0.6≤ 0.7
| No fix yet |
Description
pyshop before 0.7.1 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a download operation.
NVD description
pyshop before 0.7.1 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a download operation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free