In short
- CVE-2013-1665 is a MEDIUM (CVSS 5.0) vulnerability affecting django.
- Chance of exploitation in the next 30 days (EPSS): 4.5%, higher than 91.5% of all vulnerabilities.
- Fix: update to 1.3.6, 1.4.4 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 1.3.0, < 1.3.6≥ 1.4.0, < 1.4.4
| 1.3.61.4.4
|
Description
The XML libraries for Python as used in OpenStack Keystone Essex and Folsom, Django, and possibly other products allow remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, aka an XML External Entity (XXE) attack.
NVD description
The XML libraries for Python 3.4, 3.3, 3.2, 3.1, 2.7, and 2.6, as used in OpenStack Keystone Essex and Folsom, Django, and possibly other products allow remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, aka an XML External Entity (XXE) attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free