In short
- CVE-2013-4203 is a HIGH (CVSS 7.5) vulnerability affecting rgpg, rgpg (richard cook).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.6% of all vulnerabilities.
- Fix: update to 0.2.3 or later.
| Package | Affected versions | Patched versions |
|---|
| rgpg RubyGems | < 0.2.3
| 0.2.3
|
| rgpg | = 0.2.0= 0.2.1≤ 0.2.2
| No fix yet |
Description
The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.
NVD description
The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free