In short
- CVE-2013-6440 is a MEDIUM (CVSS 5.0) vulnerability affecting org.opensaml:opensaml, opensaml (internet2), opensaml (shibboleth).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.2% of all vulnerabilities.
- Fix: update to 2.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.opensaml:opensaml Maven | < 2.6.1
| 2.6.1
|
| opensaml | = 2.0= 2.1.0= 2.2.0
| No fix yet |
| opensaml | = 2.4.0= 2.4.1= 2.4.2= 2.4.3= 2.5.0= 2.5.1= 2.5.2= 2.5.3≤ 2.6.0
| No fix yet |
Description
The (1) BasicParserPool, (2) StaticBasicParserPool, (3) XML Decrypter, and (4) SAML Decrypter in Shibboleth OpenSAML-Java before 2.6.1 set the expandEntityReferences property to true, which allows remote attackers to conduct XML external entity (XXE) attacks via a crafted XML DOCTYPE declaration.
NVD description
The (1) BasicParserPool, (2) StaticBasicParserPool, (3) XML Decrypter, and (4) SAML Decrypter in Shibboleth OpenSAML-Java before 2.6.1 set the expandEntityReferences property to true, which allows remote attackers to conduct XML external entity (XXE) attacks via a crafted XML DOCTYPE declaration.
More vulnerabilities in org.opensaml:opensaml
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free