In short
- CVE-2013-7452 is a MEDIUM (CVSS 6.1) vulnerability affecting node.js (nodejs), validator.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.1% of all vulnerabilities.
- Fix: update to 1.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| node.js | ≤ 1.0.4
| No fix yet |
| validator npm | < 1.1.0
| 1.1.0
|
Description
The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.
NVD description
The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free