In short
- CVE-2014-0083 is a MEDIUM (CVSS 5.5) vulnerability affecting net-ldap, net-ldap (net-ldap project).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 20.1% of all vulnerabilities.
- Fix: update to 0.16.2 or later.
| Package | Affected versions | Patched versions |
|---|
| net-ldap RubyGems | < 0.16.2
| 0.16.2
|
| net-ldap | < 0.16.2
| 0.16.2
|
Description
The Ruby net-ldap gem before 0.16.2 uses a weak salt when generating SSHA passwords.
NVD description
The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free