In short
- CVE-2014-0204 is a MEDIUM (CVSS 6.5) vulnerability affecting keystone, keystone (openstack).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.4% of all vulnerabilities.
- Fix: update to 8.0.0a0, 2014.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0a0
| 8.0.0a0
|
| keystone | ≥ 2014.1, < 2014.1.1
| 2014.1.1
|
Description
OpenStack Identity (Keystone) before 2014.1.1 does not properly handle when a role is assigned to a group that has the same ID as a user, which allows remote authenticated users to gain privileges that are assigned to a group with the same ID.
NVD description
OpenStack Identity (Keystone) before 2014.1.1 does not properly handle when a role is assigned to a group that has the same ID as a user, which allows remote authenticated users to gain privileges that are assigned to a group with the same ID.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free