In short
- CVE-2014-0217 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.4% of all vulnerabilities.
- Fix: update to 2.6.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 2.6.0, < 2.6.3
| 2.6.3
|
| moodle | = 2.6.0= 2.6.1= 2.6.2
| No fix yet |
Description
enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the moodle/course:viewhiddencourses capability before listing hidden courses, which allows remote attackers to obtain sensitive name and summary information about these courses by leveraging the guest role and visiting a crafted URL.
NVD description
enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the moodle/course:viewhiddencourses capability before listing hidden courses, which allows remote attackers to obtain sensitive name and summary information about these courses by leveraging the guest role and visiting a crafted URL.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free