In short
- CVE-2014-125026 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/cloudflare/golz4, golz4 (cloudflare).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.0% of all vulnerabilities.
- Fix: update to 0.0.0-20140711154735-199f5f787806, 2014-07-11 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/cloudflare/golz4 Go | < 0.0.0-20140711154735-199f5f787806
| 0.0.0-20140711154735-199f5f787806
|
| golz4 | < 2014-07-11
| 2014-07-11
|
Description
LZ4 bindings use a deprecated C API that is vulnerable to memory corruption, which could lead to arbitrary code execution if called with untrusted user input.
NVD description
LZ4 bindings use a deprecated C API that is vulnerable to memory corruption, which could lead to arbitrary code execution if called with untrusted user input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free