In short
- CVE-2014-1972 is a HIGH (CVSS 7.8) vulnerability affecting org.apache.tapestry:tapestry-core, tapestry (apache).
- Chance of exploitation in the next 30 days (EPSS): 9.6%, higher than 95.5% of all vulnerabilities.
- Fix: update to 5.3.6 or later.
Description
Apache Tapestry before 5.3.6 relies on client-side object storage without checking whether a client has modified an object, which allows remote attackers to cause a denial of service (resource consumption) or execute arbitrary code via crafted serialized data.
NVD description
Apache Tapestry before 5.3.6 relies on client-side object storage without checking whether a client has modified an object, which allows remote attackers to cause a denial of service (resource consumption) or execute arbitrary code via crafted serialized data.
More vulnerabilities in org.apache.tapestry:tapestry-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free