In short
- CVE-2014-2538 is a MEDIUM (CVSS 4.3) vulnerability affecting rack-ssl, rack-ssl (joshua peek).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.5% of all vulnerabilities.
- Fix: update to 1.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rack-ssl RubyGems | < 1.4.0
| 1.4.0
|
| rack-ssl | = 1.0.0= 1.1.0= 1.2.0= 1.3.0= 1.3.1= 1.3.2= 1.3.3≤ 1.3.4
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.
NVD description
Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free