In short
- CVE-2014-3243 is a MEDIUM (CVSS 5.0) vulnerability affecting soappy, soappy (makina-corpus).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 85.9% of all vulnerabilities.
- Fix: update to 0.12.6 or later.
| Package | Affected versions | Patched versions |
|---|
| soappy PyPI | < 0.12.6
| 0.12.6
|
| soappy | = 0.12.5
| No fix yet |
Description
SOAPpy 0.12.5 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted SOAP request containing a large number of nested entity references.
NVD description
SOAPpy 0.12.5 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted SOAP request containing a large number of nested entity references.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free