In short
- CVE-2014-3539 is a CRITICAL (CVSS 9.8) vulnerability affecting rope, rope (rope project).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.3% of all vulnerabilities.
- Fix: update to 0.11.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rope PyPI | < 0.11.0
| 0.11.0
|
| rope | < 0.11.0
| 0.11.0
|
Description
base/oi/doa.py in the Rope library in CPython (aka Python) allows remote attackers to execute arbitrary code by leveraging an unsafe call to pickle.load.
NVD description
base/oi/doa.py in the Rope library in CPython (aka Python) allows remote attackers to execute arbitrary code by leveraging an unsafe call to pickle.load.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free