In short
- CVE-2014-4657 is a CRITICAL (CVSS 9.8) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 4.4%, higher than 91.4% of all vulnerabilities.
- Fix: update to 1.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.5.4
| 1.5.4
|
| ansible | < 1.5.4
| 1.5.4
|
Description
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
NVD description
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free