In short
- CVE-2014-4658 is a MEDIUM (CVSS 5.5) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.42%, higher than 36.2% of all vulnerabilities.
- Fix: update to 1.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.5.5
| 1.5.5
|
| ansible | < 1.5.5
| 1.5.5
|
Description
The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.
NVD description
The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free