In short
- CVE-2014-4659 is a MEDIUM (CVSS 5.5) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 30.4% of all vulnerabilities.
- Fix: update to 1.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.5.5
| 1.5.5
|
| ansible | < 1.5.5
| 1.5.5
|
Description
Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.
NVD description
Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free